Arduino:Знакомство с Arduino/Знакомство с Arduino/Genuino на Linux

Материал из Онлайн справочника
Перейти к навигации Перейти к поиску

Перевод: Максим Кузьмин (Cubewriter) Контакты:</br>* Skype: cubewriter</br>* E-mail: cubewriter@gmail.com</br>* Максим Кузьмин на freelance.ru
Проверка/Оформление/Редактирование: Мякишев Е.А.


Знакомство с Arduino/Genuino на Linux[1]

В этой статье объясняется, как подключить плату Arduino к Linux и загрузить на нее свой первый скетч.

Шаг 1. Берем Arduino/Genuino и USB-кабель

Данное руководство написано на примере плат Arduino/Genuino Uno или Arduino/Genuino Mega 2560. Если у вас какая-то другая плата, то читайте соответствующую страницу.

Кроме того, нам понадобится стандартный USB-кабель (типа A-B). Такие используются, к примеру, для подключения к принтеру. Если вы используете Arduino Nano, то вам понадобится кабель с разъемами A и Mini-B.

ArduinoUno R3 Front 450px.jpg
USBCable.jpg

Шаг 2. Загружаем IDE Arduino

Самую последнюю версию среды разработки Arduino (другое название – IDE Arduino) можно скачать отсюда. Обратите внимание, что для Linux доступно 2 версии – 32-битная и 64-битная.

Выбираем ту, которая соответствует разрядности вашей ОС. После этого запустится загрузка архива в формате «tar.xz», и когда она будет завершена, распаковываем его в нужное место.

Загружаем версию IDE Arduino (32- или 64-битную), соответствующую вашей ОС


Распаковываем архив

Шаг 3. Устанавливаем пакет

Открываем папку arduino-1.6.x и находим там файл install.sh. Кликаем по нему правой кнопкой мыши и в выпадающем меню выбираем пункт Run in Terminal. Процесс установки быстро закончится, а на рабочем столе появится новая иконка.

Если этого пункта в выпадающем меню не будет, вам нужно будет открыть окно терминала и переместиться к папке arduino-1.6.x. Впишите команду ./install.sh и подождите завершения процесса. В итоге на рабочем столе должна появиться новая иконка.

Для установки пакета, возможно, потребуется воспользоваться терминалом

Шаг 4. Подключаем плату

USB-соединение платы с компьютером требуется не только для питания, но и для того, чтобы плату можно было программировать. Модели Arduino Uno и Mega автоматически тянут питание либо от USB-соединения c компьютером, либо от внешнего блока питания. Подключите плату к компьютеру при помощи USB-кабеля – в ответ на это действие на плате должен загореться зеленый светодиод (с надписью PWR).

Шаг 5. Запускаем IDE Arduino

Делаем двойной клик по иконке IDE Arduino.

Примечание: Если IDE Arduino загрузилась с неправильным языком, его можно поменять в меню «Настройки». Более подробно читайте тут.

Шаг 6. Открываем скетч-пример Blink («Моргание»)

Для этого кликаем на Файл > Примеры > 01.Basics > Blink (File > Examples > 01.Basics > Blink).

Загружаем самый первый скетч – Blink

Шаг 7. Выбираем плату

Для этого нужно кликнуть по Инструменты > Плата (Tools > Board) и в открывшемся меню выбрать запись, соответствующую вашей Arduino/Genuino.

Выбираем плату из списка

Более подробно о меню «Плата» можно почитать в Arduino:Знакомство_с_Arduino/Среда_разработки#.D0.9F.D0.BB.D0.B0.D1.82.D1.8B статье об IDE Arduino.

Шаг 8. Выбираем порт

Это делается в списке, открывающемся при нажатии Инструменты > Порт (Tools > Serial Port). Нужная запись должна выглядеть так – /dev/ttyACM0.

Выбираем в списке порт, соответствующий вашей плате

Шаг 9. Загружаем программу

Теперь кликните по кнопке «Загрузка» в IDE Arduino. Подождите несколько секунд – вы должны увидеть, как мигают на плате светодиоды RT и TX. Если загрузка пройдет успешно, в статусной панели появится сообщение «Загрузка выполнена».

Чтобы загрузить скетч, кликаем на эту иконку

Спустя несколько секунд после завершения загрузки на плате начнет мигать светодиод (оранжевым цветом), подключенный к 13-ому контакту. Если мигает – поздравляем! Значит, отладка платы завершена! Если у вас возникли какие-то проблемы, возможно, имеет смысл обратиться к этой статье.

Если вам выдает ошибку «Error opening serial port…», это значит, что вам нужно задать разрешение на использование последовательного порта.

Открываем терминал и пишем:

ls -l /dev/ttyACM*

В ответ будет отображено что-то вроде этого:

crw-rw---- 1 root dialout 188, 0 5 apr 23.01 ttyACM0

Вместо нуля в самом конце (после «ACM») может стоять другая цифра. Кроме того, вам может выдать не одну, а несколько записей. Данные, которые нам нужны – это dialout (группа, которая владеет файлом).

Теперь нам нужно лишь добавить в группу нового пользователя...

sudo usermod -a -G dialout <username>

...где <username> – это имя пользователя Linux. Далее, чтобы изменения вступили в силу, вам нужно выйти из системы, а потом снова залогиниться.

Вот такую процедуру нужно пройти, чтобы получить доступ к последовательному порту из IDE Arduino, если вы получили ошибку

После этой процедуры все должно быть нормально – и с загрузкой скетча, и с использованием «Монитора порта».

Возможно, вам также будут интересны:

См.также

Внешние ссылки