Arduino:Знакомство с Arduino/Знакомство с Arduino/Genuino на Mac OS X

Материал из Онлайн справочника
Перейти к навигации Перейти к поиску

Перевод: Максим Кузьмин (Cubewriter) Контакты:</br>* Skype: cubewriter</br>* E-mail: cubewriter@gmail.com</br>* Максим Кузьмин на freelance.ru
Проверка/Оформление/Редактирование: Мякишев Е.А.


Знакомство с Arduino-Genuino на Mac OS X[1]

В этой статье объясняется, как подключить плату Arduino к Mac и загрузить на нее свой первый скетч.

Шаг 1. Берем Arduino/Genuino и USB-кабель

Данное руководство написано на примере плат Arduino Uno или Arduino Mega 2560. Если у вас какая-то другая плата, то читайте соответствующую страницу.

Кроме того, нам понадобится стандартный USB-кабель (типа A-B). Такие используются, к примеру, для подключения к принтеру. Если вы используете Arduino Nano, то вам понадобится кабель с разъемами A и Mini-B.

ArduinoUno R3 Front 450px.jpg
USBCable.jpg

Шаг 2. Загружаем IDE Arduino

Самую последнюю версию среды разработки Arduino (другое название – IDE Arduino) можно скачать отсюда. Когда загрузка будет завершена, сделайте двойной клик по ZIP-файлу – это распакует IDE Arduino.

Шаг 3. Устанавливаем IDE Arduino

Копируем папку с IDE Arduino в папку с программами (впрочем, это не обязательно; ее можно скопировать в любое место). Если вы используете Arduino Uno или Mega 2560, то драйверы устанавливать не нужно.

Шаг 4. Подключаем плату

Модели Arduino Uno и Mega автоматически тянут питание либо от USB-соединения c компьютером, либо от внешнего блока питания. Источник питания выбирается при помощи перемычки – маленькой пластиковой детали, сидящей на двух из трех штырьков-контактов, которые находятся между разъемами для питания и USB. Удостоверьтесь, что эта перемычка сидит на двух контактах, находящихся ближе к USB-порту.

Подключите Arduino к компьютеру при помощи USB-кабеля – в ответ на это действие на плате должен загореться зеленый светодиод (с надписью PWR).

Шаг 5. Запускаем IDE Arduino

Делаем двойной клик по иконке IDE Arduino.

Примечание: Если IDE Arduino загрузилась с неправильным языком, его можно поменять в меню «Настройки». Более подробно читайте тут.

Шаг 6. Открываем скетч-пример Blink («Моргание»)

Для этого кликаем на Файл > Примеры > 01.Basics > Blink (File > Examples > 01.Basics > Blink).

Arduino1Blink 1.png

Шаг 7. Выбираем плату

Для этого нужно кликнуть по Инструменты > Плата (Tools > Board) и в открывшемся меню выбрать запись, соответствующую вашей Arduino.

Выбор Arduino Uno

Более подробно о меню «Плата» можно почитать в статье об IDE Arduino.

Шаг 8. Выбираем порт

В меню Инструменты > Порт (Tools > Serial Port) выбираем порт, к которому подключена плата. На Mac это должно быть что-то вроде /dev/tty.usbmodem (для Uno или Mega 2560) или /dev/tty.usbserial (для более старых моделей).

Выбор Uno, Mega 2560 или более новой модели


Выбор более старой модели с FTDI-драйверами


Шаг 9. Загружаем программу

Теперь кликните по кнопке «Загрузка» в IDE Arduino. Подождите несколько секунд – вы должны увидеть, как мигают на плате светодиоды RT и TX. Если загрузка пройдет успешно, в статусной панели появится сообщение «Загрузка выполнена».

Примечание: Если у вас Arduino Mini, NG или другая плата, то прямо перед нажатием кнопки «Загрузка» в IDE Arduino вам надо будет вручную нажать кнопку сброса на плате.

UploadButton1 5.png

Спустя несколько секунд после завершения загрузки на плате начнет мигать светодиод (оранжевым цветом), подключенный к 13-ому контакту. Если мигает – поздравляем! Значит, отладка платы завершена! Если у вас возникли какие-то проблемы, возможно, имеет смысл обратиться к этой статье.

Возможно, вам также будут интересны:

См.также

Внешние ссылки