Arduino:Знакомство с Arduino/Знакомство с Arduino/Genuino на Windows

Материал из Онлайн справочника
Перейти к навигации Перейти к поиску

Перевод: Максим Кузьмин (Cubewriter) Контакты:</br>* Skype: cubewriter</br>* E-mail: cubewriter@gmail.com</br>* Максим Кузьмин на freelance.ru
Проверка/Оформление/Редактирование: Мякишев Е.А.


Знакомство с Arduino/Genuino на Windows[1]

В этой статье объясняется, как подключить плату Arduino и загрузить на нее свой первый скетч.

Шаг 1. Берем Arduino/Genuino и USB-кабель

Данное руководство написано на примере плат Arduino/Genuino Uno или Arduino/Genuino Mega 2560. Если вы используете старую модель вроде Arduino Duemilanove, Nano или Diecimila, обратитесь к самому последнему разделу этой статьи – там изложены инструкции по установке драйверов. Если у вас какая-то другая плата, то читайте соответствующую страницу.

Кроме того, нам понадобится стандартный USB-кабель (типа A-B). Такие используются, к примеру, для подключения к принтеру.


ArduinoUno R3 Front 450px.jpg


USBCable.jpg

Шаг 2. Загружаем и устанавливаем IDE Arduino

Самую последнюю версию среды разработки Arduino (или IDE Arduino) можно скачать отсюда. Она доступна в виде либо установщика (exe-файла), либо ZIP-архива. Если вы решили скачать exe-файл, то он напрямую устанавливает все, что может потребоваться для работы IDE Arduino, включая драйверы. Но если вы решили воспользоваться ZIP-архивом, то драйверы придется устанавливать вручную.

Когда загрузка будет завершена, запустите exe-файл и разрешите установку драйвера.

Выберите нужные компоненты


Выберите папку для установки (предположим, вы решили оставить ту, что была указана по умолчанию)


Далее установщик начнет извлечение и установку файлов, необходимых для работы IDE Arduino

Шаг 3. Подключаем плату

Подключение по USB к компьютеру необходимо не только для того, чтобы питать плату, но и чтобы программировать ее. Модели Uno и Mega автоматически тянут питание либо от USB-соединения, либо от внешнего блока питания. Подключите плату к компьютеру при помощи USB-кабеля – в ответ на это действие на плате должен загореться зеленый светодиод (с надписью PWR).

Шаг 4. Устанавливаем драйверы для платы

Если вы используете установщик, то Windows (от XP до 10) установит драйверы автоматически, как только вы подключитесь к плате.

Если вы загрузили и распаковали ZIP-архив или если компьютер по какой-то причине не распознал плату, следуйте следующим инструкциям:

  • Нажмите кнопку «Пуск»Windows 8 – нажмите комбинацию клавиш  Win  +  X ) и выберите «Панель управления».
  • Будучи в «Панели управления», выберите пункт «Система и безопасность», затем «Система» и, наконец, «Диспетчер устройств».
  • Загляните в пункт «Порты (COM и LPT)». Здесь должен быть открытый порт под названием «Arduino UNO (COMxx)». Если пункта «Порты (COM и LPT)» нет, ищите пункт «Другие устройства», а в нем – запись «Неизвестное устройство».
  • Правой кнопкой мыши кликните по порту «Arduino UNO (COMxx)» и выберите пункт «Обновить драйверы...»
  • Далее выберите «Выполнить поиск драйверов на этом компьютере».
  • Кликните на «Обзор...» и выберите файл с драйвером под названием «arduino.inf». Он находится в папке IDE Arduino в подпапке Drivers (но не в папке FTDI USB Drivers, которая находится внутри Drivers). Если вы используете старую версию IDE Arduino (1.0.3 и старше), выберите файл (для Uno) под названием «Arduino UNO.inf».
  • Далее Windows сама выполнит установку.

Шаг 5. Запускаем IDE Arduino

Делаем двойной клик по иконке Arduino (arduino.exe), созданной процессом установки.

Примечание: Если IDE Arduino загрузилась с неправильным языком, его можно поменять в меню «Настройки». Более подробно читайте тут.

Шаг 6. Открываем скетч-пример Blink («Моргание»)

Сделать это можно, кликнув Файл > Примеры > 01.Basics > Blink (File > Examples > 01.Basics > Blink).

Знакомство с ArduinoGenuino на Windows blink.jpg

Шаг 7. Выбираем плату

Для этого нужно кликнуть по Инструменты > Плата (Tools > Board) и в открывшемся меню выбрать запись, соответствующую вашей плате Arduino/Genuino.

Выбор Arduino/Genuino Uno

Более подробно о меню «Плата» можно почитать в статье об IDE Arduino.

Шаг 8. Выбираем порт

В меню Инструменты > Порт (Tools > Serial Port) выбираем порт, к которому подключена плата. Скорее всего, это будет COM3 или выше (потому что COM1 и COM2 уже зарезервированы под аппаратные последовательные порты). Чтобы понять, какой именно порт вам нужен, отключите плату и снова откройте это меню. Запись, которая исчезнет – это и есть порт, к которому подключена Arduino/Genuino. Снова подключите плату и выберите нужный порт.

Шаг 9. Загружаем программу

Теперь кликните по кнопке «Загрузка» в IDE Arduino. Подождите несколько секунд – вы должны увидеть, как мигают на плате светодиоды RT и TX. Если загрузка пройдет успешно, в статусной панели появится сообщение «Загрузка выполнена».

Знакомство с ArduinoGenuino на Windows upload.png

Спустя несколько секунд после завершения загрузки на плате начнет мигать светодиод (оранжевым цветом), подключенный к 13-ому контакту. Если мигает – поздравляем! Значит, отладка платы завершена! Если у вас возникли какие-то проблемы, возможно, имеет смысл обратиться к этой статье.

Для устаревших моделей Arduino

В этом разделе будет описано, как установить драйверы для Arduino Duemilanove, Nano и Diecimila на Windows 7, Vista или XP.

Когда вы подключите плату, Windows должна запустить процесс установки драйверов (но лишь в том случае, если вы раньше никогда не использовали этот компьютер для Arduino).

На Windows Vista драйвер должен загрузиться и установиться автоматически (это действительно работает!).

На Windows XP откроется «Мастер установки оборудования»:

  • Когда вас спросят «Разрешить подключение к узлу Windows Update для поиска программного обеспечения?», выбираем «Нет, не в этот раз». Затем кликаем «Далее».
  • Выбираем «Установка из указанного места» и кликаем «Далее».
  • Ставим галочку в пункте «Выполнить поиск наиболее подходящего драйвера в указанных местах», убираем галочку с «Поиск на сменных носителях», ставим галочку на «Включить следующее место поиска», а затем кликаем по «Обзор...» и выбираем подпапку drivers/FTDI USB Drivers, находящуюся в директории с установленной IDE Arduino. Кроме того, последнюю версию драйверов можно найти на сайте FTDI. Теперь кликаем «Далее».
  • Далее «Мастер» начнет искать драйвер, а затем скажет, что был найден «USB Serial Converter». Кликаем на «Готово».
  • Появится еще одно окно с «Мастером установки оборудования». Проходим те же шаги, выбираем те же пункты и место для поиска. Но на этот раз будет найден «USB Serial Port».

Проверить, установились ли драйверы, можно через «Диспетчер устройств» (его можно найти по маршруту «Панель управления» > «Система и безопасность» > «Система»). Ищите пункт «Порты (COM и LPT)», а в нем – запись «USB Serial Port». Это и есть плата Arduino.

Возможно, вам также будут интересны:

См.также

Внешние ссылки