Arduino:Знакомство с Arduino/Знакомство с Intel Edison

Материал из Онлайн справочника
Перейти к навигации Перейти к поиску

Перевод: Максим Кузьмин (Cubewriter) Контакты:</br>* Skype: cubewriter</br>* E-mail: cubewriter@gmail.com</br>* Максим Кузьмин на freelance.ru
Проверка/Оформление/Редактирование: Мякишев Е.А.


Знакомство с Intel Edison[1]

В этом руководстве объясняется, как начать работать с Intel Edison.

Предполагается, что читающий это руководство использует набор Intel Edison для Arduino, но это верно и для макетной платы Intel Edison. Кроме того, предполагается, что модуль Intel Edison уже подключен к макетной плате. Если нет, подключите. О том, как это сделать, описано тут.

Загрузка IDE Arduino

Самый первый шаг (если вы его еще не сделали) – загружаем с соответствующей страницы среду разработки Arduino (или просто IDE Arduino).

Подключение платы к ПК

Чтобы загружать Arduino-скетчи на Intel Edison, плата должна быть запитана и подключена к компьютеру. Предполагается, что для подключения платы к ПК будут использоваться два кабеля с разъемами типа micro USB, потому что таким образом плате будет доступно больше тока (на тот случай, если потребуется).

Найдите на плате маленький переключатель – он находится между USB-портами. Переключите его вниз, в сторону портов micro USB, как показано на рисунке ниже:

Edisonimg8.jpg

На плате должен загореться зеленый огонек. Если не загорелся, проверьте соединение.

Edison imgE.jpg

Подождите, пока плата загрузится. О том, что плата полностью инициализировалась, можно будет узнать по тому, что на компьютер смонтируется новый диск (это как если бы в ваш компьютер была вставлена SD-карта).

Примечание: Если новый диск не появился, а светодиод (на расширительной плате Arduino это DS1) в случайном порядке то включается-выключается, это значит, что компьютер дает плате недостаточно тока. В этом случае можно воспользоваться источником переменного тока, и о том, как это сделать, можно прочитать в этом руководстве.

Открываем пример «Blink»

Заходим в IDE Arduino и открываем скетч-пример «Blink». Для этого кликаем по пункту Файл > Примеры > 01.Basics > Blink (File > Examples > 01.Basics > Blink).

Выбираем плату

Заходим в меню Инструменты > Плата (Tools > Board) и выбираем там пункт Intel Edison, как показано ниже:

Edison img7 1.jpg

Выбираем порт

Заходим в меню Инструменты > Порт (Tools > Port) и выбираем нужный последовательный порт. Самый простой способ понять, какой порт использует ваша плата – это отключить плату, перезапустить IDE Arduino и снова открыть меню Port. Запись, которая исчезнет, и будет портом для Intel Edison. Теперь переподключаем плату, перезапускаем IDE Arduino и снова выбираем нужный порт.

На Windows

На этой ОС нужным портом, скорее всего, будет COM3 или выше, а в «Менеджере устройств» он будет отображаться как «Intel Edison Virtual Com Port», а НЕ «USB Serial Port». Варианты COM1 и COM2 обычно зарезервированы под аппаратные последовательные порты.

Edison img14 2.png

На Linux

Здесь нужным портом, скорее всего, будет /dev/ttyACM1:

Edison linux port select 3.png

На Mac OS X

Здесь нужным портом, скорее всего, будет /dev/cu.usbmodemxxxx. Если у вас много подобных записей, то выберите любую из них – это должно дать те же результаты:

Edison osx port select 4.png

Загружаем и запускаем программу

Кликаем на кнопку «Загрузка» в левой верхней части IDE Arduino и запускаем скетч:

Edison img12 5.png

Когда скетч будет загружен, вы должны увидеть запись «Загрузка завершена»:

Edison img15 6.png

В результате на плате должен замигать (с секундной задержкой) светодиод DS2.

Edison imgB 7.jpg

Обучение

Ниже – список статей с примерами устройств, которые можно создать на базе Intel Edison:

См.также

Внешние ссылки