Arduino:Знакомство с Arduino/Знакомство с Arduino Mega 2560

Материал из Онлайн справочника
Перейти к навигации Перейти к поиску

Перевод: Максим Кузьмин (Cubewriter) Контакты:</br>* Skype: cubewriter</br>* E-mail: cubewriter@gmail.com</br>* Максим Кузьмин на freelance.ru
Проверка/Оформление/Редактирование: Мякишев Е.А.


Знакомство с Arduino Mega 2560[1]

Arduino Mega 2560 разработана для проектов, где требуется больше I/O контактов, больше памяти для скетчей и больше оперативной памяти. Она имеет 54 I/O контакта, 16 входных аналоговых контактов и рекомендуется для использования в 3D-принтерах и проектах, связанных с робототехникой. Эта статья объясняет, как подключить плату Mega 2560 к компьютеру и загрузить свой первый скетч.

Плата Arduino Mega 2560 программируется при помощи IDE Arduino – интегрированной среды разработки, которая используется для всех плат Arduino. Она доступна и оффлайн, и онлайн. Более подробно с IDE Arduino можно ознакомиться тут.

Использование Arduino Mega 2560 с онлайновым IDE Arduino

Все платы Arduino/Genuino (включая ту, что описывается тут) безо всяких дополнительных настроек работают с веб-редактором Arduino, не требующим никакой установки.

Это онлайновый редактор, поэтому он всегда оснащен самыми последними обновлениями и поддерживает все платы. О том, как начать программировать прямо в браузере, а затем загружать оттуда скетч на плату, можно почитать в этом руководстве.

Использование Arduino Mega 2560 с компьютерным IDE Arduino

Если вы хотите программировать Arduino Mega 2560, будучи оффлайн, вам нужно установить оффлайн-версию IDE Arduino.

Подключите плату

Подключите вашу Arduino Mega 2560 при помощи USB-кабеля типа «A-B» (его еще называют «принтерным»).

A000067 iso both.jpg
USBCable.jpg

USB-соединение с PC необходимо не только для питания, но и для программирования платы. Mega 2560 будет автоматически получать питание либо от USB, либо от внешнего источника питания. Подключите плату к компьютеру при помощи USB-кабеля. В результате должен загореться зеленый светодиод (под названием PWR).

Откройте скетч

Откройте скетч-пример «Blink». Для этого кликните в IDE Arduino на Файл > Примеры > 01.Basics > Blink (File > Examples > 01.Basics > Blink).

UNO Load Blink 1.jpg

Выберите тип платы и порт

Кликните на Инструменты > Плата (Tools > Board) и в появившемся меню выберите пункт, соответствующий вашей плате Arduino/Genuino. У нас Mega 2560, поэтому по умолчанию процессором будет выбран ATmega2560.

MEGA BoardType 2.jpg

Далее кликните на Инструменты > Порт (Tools > Port) и выберите нужный пункт. Скорее всего, это будет COM3 или выше (COM1 и COM2, как правило, зарезервированы для аппаратных последовательных портов). Чтобы найти правильный порт, отключите плату и заново откройте это меню – исчезнувший пункт и будет портом, к которому подключена ваша плата Arduino/Genuino. Снова подключите плату и выберите нужный последовательный порт.

MEGA Port 3.jpg

Загрузите скетч

Теперь просто кликаем на кнопку «Загрузка» в IDE Arduino. Ждем несколько секунд – вы должны увидеть, как на плате мигают светодиоды RX и TX. Если загрузка пройдет успешно, в статусной панели появится сообщение «Загрузка завершена».

UNO Upload 4.png

Спустя несколько секунд после завершения загрузки вы должны увидеть мигание на светодиоде, подключенном к 13-ому контакту. Если увидели – поздравляем! Плата успешно работает. Если у вас возникли какие-то проблемы, смотрите здесь.

Проекты

Теперь, когда вы настроили свою Arduino Mega 2560, можно ознакомиться с проектами на Project Hub – платформе с руководствами на официальном сайте Arduino.

Также можно ознакомиться с другими материалами на нашем сайте, которые объясняют, как использовать функционал Mega 2560:

См.также

Внешние ссылки