Arduino:Знакомство с Arduino/Знакомство с Intel® Galileo Gen2

Материал из Онлайн справочника
Перейти к навигации Перейти к поиску

Перевод: Максим Кузьмин (Cubewriter) Контакты:</br>* Skype: cubewriter</br>* E-mail: cubewriter@gmail.com</br>* Максим Кузьмин на freelance.ru
Проверка/Оформление/Редактирование: Мякишев Е.А.


Знакомство с Intel® Galileo Gen2[1]

В этом руководстве будет рассказываться, как начать работать с Intel Galileo Gen2.

Загружаем IDE Arduino

Это самый первый шаг, и если вы его еще не сделали, то заходим на страницу загрузок на официальном сайте Arduino и загружаем оттуда программу IDE Arduino.

Устанавливаем ядро Intel i586

Еще один предварительный шаг – вам нужно установить в IDE Arduino ядро, поддерживающее плату Galileo.

Для этого кликаем по Инструменты > Плата > Менеджер плат (Tools > Board > Board Manager):

BoardManagerGalileo 1.png

Откроется «Менеджер плат». Выбираем ядро «Intel i586» и кликаем по кнопке «Установка»:

BoardManager2Galileo 2.png

Ждем, пока IDE Arduino выполнит установку.

Подключаем плату к ПК

Модель Galileo подключается к компьютеру через micro-USB кабель. Однако перед этим плату нужно обязательно запитать от внешнего источника питания. «Голое» USB-подключение приведет к повреждению Galileo.

Открываем пример Blink

Запускаем IDE Arduino и выбираем там скетч пример «Blink». Для этого кликаем по Файл > Примеры > 01.Basics > Blink (File > Examples > 01.Basics > Blink).

Выбираем плату

Открываем меню Инструменты > Плата (Tools > Board) и выбираем там пункт Intel Galileo Gen2:

GalileoBoard 3.jpg

Выбираем порт

Открываем меню Инструменты > Порт (Tools > Port) и выбираем в нем нужный последовательный порт. Самый простой способ понять, какой порт использует ваша плата – это отключить плату, перезапустить IDE Arduino и снова открыть меню Port. Запись, которая исчезнет, и будет портом для Intel Edison. Теперь переподключаем плату, перезапускаем IDE Arduino и вбираем найденный порт.

На Windows

На этой ОС нужным портом, скорее всего, будет COM3 или выше, а в «Менеджере устройств» он будет отображаться как «Intel Galileo Gen2 Virtual Com Port», а НЕ «USB Serial Port». Варианты COM1 и COM2 обычно зарезервированы под аппаратные последовательные порты.

GalileoWin 4.png

На Linux

Здесь нужным портом, скорее всего, будет /dev/ttyACM1:

GalileoPort 5.png

На Mac OS X

Здесь нужным портом, скорее всего, будет /dev/cu.usbmodemxxxx. Если у вас много подобных записей, то выберите любую из них – это должно дать те же результаты:

Edison osx port select 6.png

Загружаем и запускаем программу

Кликаем на кнопку «Загрузка» в левой верхней части IDE Arduino и запускаем скетч:

GalileoUpload 7.png

Когда скетч будет загружен, вы должны увидеть запись «Загрузка завершена». В ответ на это действие на плате должен замигать встроенный светодиод.

GalileoComplete 8.png

Обучение

Ниже – список статей с примерами устройств, которые можно создать на базе Intel Edison:

См.также

Внешние ссылки