Arduino:Хакинг/Настройки Arduino

Материал из Онлайн справочника
Перейти к навигации Перейти к поиску

Перевод: Максим Кузьмин (Cubewriter) Контакты:</br>* Skype: cubewriter</br>* E-mail: cubewriter@gmail.com</br>* Максим Кузьмин на freelance.ru
Проверка/Оформление/Редактирование: Мякишев Е.А.


Pixel Art Mini Meow Animated.gif Черновик


Настройки Arduino[1]

Некоторыми настройками Arduino можно управлять из меню «Настройки» в IDE Arduino. На Windows и Linux доступ к нему осуществляется через меню «Файл», а на Mac – через меню «Arduino».

Прочими настройками можно управлять в файле «preferences.txt». Месторасположение этого файла можно увидеть в нижней части окна «Настройки». На разных платформах этот файл располагается в разных местах:

1 /Users/<USERNAME>/Library/Arduino/preferences.txt (Mac)
2 c:\Documents and Settings\<USERNAME>\Application Data\Arduino\preferences.txt (Windows XP)
3 c:\Users\<USERNAME>\AppData\Roaming\Arduino\preferences.txt (Windows Vista)
4 ~/.arduino/preferences.txt (Linux)

Редактируйте этот файл, только когда IDE Arduino закрыта. В противном случае ваши настройки будут перезаписаны при выходе из IDE Arduino.

Пункты в меню Инструменты > Плата можно поменять в файле «board.txt», который на Win 8 находится по адресу

«C:\Program Files (x86)\Arduino\hardware\arduino\avr»

Содержимое меню Инструменты > Записать загрузчик можно поменять в файле «programmers.txt», который находится в той же папке. Чтобы создать новый пункт для платы или программатора, скопируйте уже существующий пункт, поменяйте префикс (например, «diecimila» или «avrisp»), а затем измените значения, чтобы они соответствовали вашему устройству. Имейте в виду, что поддерживаются лишь определенные конфигурации. Более подробно читайте на странице, описывающей другое оборудование.

См.также

Внешние ссылки